News Feature Releases Technical — Kafka Wednesday 15th September 2021

Updates to Instaclustr Support for Earlier Versions of Apache Kafka

By Instaclustr

As the official release of Kafka 3.0 approaches, we want to advise the retirement of some older versions of Kafka. The Apache Kafka project follows a time-based release plan and aims to support the 3 most recent versions, meaning versions 2.8.x, 2.7.x, and 2.6.x are currently supported by the Apache Kafka project.

With the Apache Kafka project in mind, Instaclustr will transition towards limiting support to the latest 3 versions of Kafka and Kafka Connect available on the Instaclustr Managed Platform. As versions are retired, Instaclustr will fully support these versions for an additional 6 months. Beyond this only critical fixes will be applied. For example, once Apache Kafka version 2.8.1 is released for general availability on the Instaclustr platform, version 2.5.1 will be retired and customers running version 2.5.1 will be supported for an additional 6 months.

Instaclustr has favored support for the 2.x.1 versions, which benefit from post release bug fixes and thus improved reliability for our customers. Instaclustr will continue to offer Apache Kafka and Kafka Connect versions 2.7.1, 2.6.1, and 2.5.1 on the Instaclustr Managed Platform.

For customers running 2.4.1 and below, Instaclustr will continue to support these versions for our customers for 6 months, from today until February 15, 2022. During this period, extended support will be limited to critical issues only. Our support teams will be contacting you shortly to commence discussions on how to manage your migration.

Our extended support is provided to enable customers to plan their upgrades and migrations with confidence. Stay tuned for more information on Kafka 3.0, features, and performance benefits once it becomes available. If you have any further concerns or wish to discuss migration, please get in touch with your Customer Success representative.